RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×


Reply
 
Thread Tools Display Modes
Old 09-28-2020, 08:57 PM   #1
Junior Member
 
Join Date: Jul 2017
Location: Lancaster, PA
Posts: 4
Our own Ground Hog day with the odometer

We have a 2014 Berkshire 400QL diesel Motorhome. 2 weeks ago the odometer stopped at 40349. Upon recommendation from the shop that usually does our chassis work, we took it to a shop that deals with speedometers & electronics. (We have used them before in another vehicle). They replaced the computer module and, following a test drive, called to say it was repaired. Upon picking it up, it was at 40349, but did change as we drove home. Yeah, all good. Not! Got in the next day to head out camping - back to 40349. Went about 70 miles, all registered. Started up to come home - back to 40349!! Before module was replaced it was actually stuck at that number. Now it actually shows the mileage traveled, but resets when turned off and back on. Trip mileage works ok. Anyone ever run into this?
DougMcC is offline   Reply With Quote
Old 09-30-2020, 08:44 PM   #2
Senior Member
 
Join Date: Jul 2014
Posts: 387
I had a Lincoln continental same thing dealer tried everything a few times but nothing worked. Sometimes it would be say 90000 miles sometimes 14000. They took it back on trade
retired on a mountain is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



All times are GMT -5. The time now is 09:37 PM.