Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   FR3 (https://www.forestriverforums.com/forums/f232/)
-   -   FR3: Taillights on toad not working (https://www.forestriverforums.com/forums/f232/fr3-taillights-on-toad-not-working-169427.html)

OKHerbie 09-01-2018 12:08 AM

FR3: Taillights on toad not working
 
I have not found anybody else having this problem, but here goes:
I am pulling my wife's 2016 Ford Edge behind our 2017 FR3. Brakelights and blinkers work ok but the car's taillights don't while plugged in. All lights on the RV work fine and everything works on the car while not plugged in. Using a voltmeter I found that there is zero volts for taillights at the plug-in at the RV. I suspect there must be fuses for this somewhere, but WHERE? Has anybody found this?

Carl17 09-01-2018 06:59 AM

Fuse
 
There are Fuses by driver side left of brake pedal and out side driver side fire wall . Should tell you in manual.

OKHerbie 09-01-2018 10:04 PM

Still searching for fuses
 
Yes Carl, that manual should say, however it is very vague and generically addresses all gas class Ones, rather than this specific model. I did see the fuse box next to the brake pedal but just can't squeeze myself into position to check it without removing the seat, which I have not yet dared to do. I'll investigate the fuses forward of the firewall. Thanks for your your thoughts

OKHerbie 09-03-2018 11:14 PM

Fuse found
 
Ok, Carl, you were right, the manual did say. I started by looking in the FR manual but fuses for trailer towing are, of course, covered in the F53 manual.
End of story: found fuse, replaced, all good.
Thanks again


All times are GMT -5. The time now is 03:09 PM.