Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   Appliances and Electronics (https://www.forestriverforums.com/forums/f113/)
-   -   Light not lit on outside power-outlet cover (https://www.forestriverforums.com/forums/f113/light-not-lit-on-outside-power-outlet-cover-172011.html)

RooMan183 10-09-2018 05:50 PM

Light not lit on outside power-outlet cover
 
1 Attachment(s)
The light on on this cover is not lit. There is power inside the trailer. Is there something I should check to make sure I'm getting the proper amperage? I checked the fuse box and nothing was tripped. I didn't check all the small fuses though. I've attached a pic. Any help would be greatly appreciated.

Thanks

Toddupton 10-09-2018 05:59 PM

Those lights go out all the time. Sometimes they will come back on and sometimes not. Just ignore it not telling you anything is wrong with your power.

Mr. Dan 10-09-2018 06:02 PM

Quote:

Originally Posted by Toddupton (Post 1946545)
Those lights go out all the time. Sometimes they will come back on and sometimes not. Just ignore it not telling you anything is wrong with your power.

You should appreciate this help. It is spot on.

Mch5jdm 10-09-2018 09:27 PM

I was wondering the same. Worked fine at first then suddenly stopped.

5picker 10-09-2018 09:33 PM

There are lots of reports here of the light failing. Some had the port replaced under warranty only to have it fail again in a few months.

Someone took their's apart to try and fix it but didn't have much luck.

Mine failed at about 10 months.
Never worried about it.

immecor 10-09-2018 11:21 PM

Yeah mine went out as well after the first couple trips. Had it replaced under warranty. They put a new type on with a half moon light and has been good for about a year so far.

russhd1997 10-10-2018 05:34 AM

Quote:

Originally Posted by Toddupton (Post 1946545)
Those lights go out all the time. Sometimes they will come back on and sometimes not. Just ignore it not telling you anything is wrong with your power.

Mine does the same, sometimes it works and sometimes it doesn't. As long as you've got power inside the camper it's nothing to worry about. The lights at the plug stopped working on mine too.

youroo 10-10-2018 06:38 AM

Our Factory power inlet receptacle is White and has no light, our Factory power cord is Yellow and has a LED light that" works" molded into the Screw Thread end! The newer power supply Receptacle box's and cords are Black and have LED indicator Light issue's,! :trink39: Youroo! !

jeff64 10-10-2018 06:58 AM

Mine hasn't worked for a long time. No Biggie!

Bill and Gail 10-10-2018 07:41 AM

Mine went out after 1 year. Everything was working, so I just ignored it. It's still out for over a year now.

Stlcaly 10-10-2018 12:38 PM

I was really excited to see this and hoped that I would finally get the answer to the same problem that the writer had. Reluctantly I have the same problem and don’t pay any attention to it

mudman2 10-10-2018 12:48 PM

Quote:

Originally Posted by Stlcaly (Post 1947138)
I was really excited to see this and hoped that I would finally get the answer to the same problem that the writer had. Reluctantly I have the same problem and donít pay any attention to it

X2

rlh1957 10-10-2018 01:10 PM

These Furrion power led lights go out quite common. On one unit it went out, Furrion sent a replacement and said they go out. Replacement lasted about 3 months before going out. No problem. Just an indicator led. Not replaceable.
Got a new rig now... that Furrion indicator light lasted 6 months, then dark.
I dont even worry about it.

NorSnrub 10-10-2018 01:28 PM

My power cord had 2 they both failed. Still works just look inside an see if tv, microwave, or anything else comes on.

Chazman 10-10-2018 02:59 PM

Well it SHOULD work....
 
Our Rockwood 8311 is 3 months old and the light quit. Just because it happens to everyone, doesn't make it right. I'm planning on getting a replacement under warranty. If enough people complain maybe they'll start supplying a decent one. Just MHO.

awellis3 10-11-2018 02:36 PM

Quote:

Originally Posted by NorSnrub (Post 1947184)
...just look inside an see if tv, microwave, or anything else comes on.

Or listen for the microwave to go "beep."

Ejs4029 10-11-2018 02:47 PM

Quote:

Originally Posted by jeff64 (Post 1946858)
Mine hasn't worked for a long time. No Biggie!

X2.....Mine quit working :eek:


All times are GMT -5. The time now is 02:29 PM.