Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   Appliances and Electronics (https://www.forestriverforums.com/forums/f113/)
-   -   Dometic refrigerator Inop (https://www.forestriverforums.com/forums/f113/dometic-refrigerator-inop-173906.html)

John24RLS 11-07-2018 11:38 PM

Dometic refrigerator Inop
 
Hi Guys, I have a Dometic DMR702 fridge. It has stopped working. The control board functions normal. The power, 120volt, and 12volt shows normal on the back. When propane is selected on the control board it lights off normal. No cooling on either propane or electric. The gas tubes on top warm up and the cooling fans come on like normal. but the lower gas tubes do not heat up. The fridge is 1 year old and has been plugged into AC most of its life. There are no code via flashing lights shown on the control panel. Have not checked the fuse on the power circuit board on the back yet. Does anybody know what the part number is for the power circuit board on the back?
Thanks John

Toddupton 11-08-2018 08:08 AM

If it lights up and stays lit then nothing is wrong with the board. How long has it been running before you checked the temp? If the freezer getting cold at all?

Flybob 11-08-2018 08:21 AM

Quote:

Originally Posted by John24RLS (Post 1967773)
The fridge is 1 year old and has been plugged into AC most of its life.




Are you saying the fridge has been running continually for a year?

John24RLS 11-08-2018 09:23 AM

Quote:

Originally Posted by Toddupton (Post 1967831)
If it lights up and stays lit then nothing is wrong with the board. How long has it been running before you checked the temp? If the freezer getting cold at all?

Neither the freezer or the fridge is getting cold.
It has been running at least a week before checking late yesterday evening to find I had a problem.
Yes, been running continually for a year.

I want to go camping thanksgiving week so donít have time to take to a dealer. If I can figure out the problem will repair myself. Itís a 2017 model.

MR.M 11-08-2018 09:28 AM

Quote:

Originally Posted by John24RLS (Post 1967889)
Neither the freezer or the fridge is getting cold.
It has been running at least a week before checking late yesterday evening to find I had a problem.
Yes, been running continually for a year.

I want to go camping thanksgiving week so donít have time to take to a dealer. If I can figure out the problem will repair myself. Itís a 2017 model.

do you or did you have an ammonia smell. do you see and yellow staining in the back piping ? if not shut off let the boiler cool down and try again .

John24RLS 11-08-2018 09:34 AM

Quote:

Originally Posted by MR.M (Post 1967896)
do you or did you have an ammonia smell. do you see and yellow staining in the back piping ? if not shut off let the boiler cool down and try again .

I’m at work till late afternoon today. Didn’t smell ammonia last night. Turned it off last night, will try it again this afternoon. Will check for yellow staining this afternoon.
What is the fuse for on the rear electric control module?

Thanks

Bama Rambler 11-08-2018 09:35 AM

It's sounding like the cooling system has leaked, but Mr.M has a good idea of shutting it off for a day and restarting it to see if it will start back.

How level is the RV?

5picker 11-08-2018 09:56 AM

Quote:

Originally Posted by John24RLS (Post 1967904)
I’m at work till late afternoon today. Didn’t smell ammonia last night. Turned it off last night, will try it again this afternoon. Will check for yellow staining this afternoon.
What is the fuse for on the rear electric control module?

Thanks

There should be a couple of fuses... one a 5a automotive blade type fuse for the 12v side of things and a glass tube type fuse for the 120v side of things. You can check them both with a multimeter.

John24RLS 11-08-2018 10:00 AM

Quote:

Originally Posted by Bama Rambler (Post 1967905)
It's sounding like the cooling system has leaked, but Mr.M has a good idea of shutting it off for a day and restarting it to see if it will start back.

How level is the RV?

It is pretty level. Bubble inside the lines on the four cardinal headings.

Iím going to check the fuses this afternoon.

5picker 11-08-2018 10:07 AM

Were the tubes warm on electric operation before you switched to LP?
If so, the fuses are fine.

I think you have a bad cooling unit.

If the flue and some of the tubes get warm in both modes of operation but the refrigerator doesn't cool, it likely went bad.

MR.M 11-08-2018 10:13 AM

Quote:

Originally Posted by John24RLS (Post 1967904)
Iím at work till late afternoon today. Didnít smell ammonia last night. Turned it off last night, will try it again this afternoon. Will check for yellow staining this afternoon.
What is the fuse for on the rear electric control module?

Thanks

there are several fuses . but if it had power and was heating and the upper control panel is on then the fuses are ok . sometimes these unit will get a bubble that stops flow and b y shutting it down it allows the bubble to be absorbed and will start flowing again , not the first time i've seen this happen .

John24RLS 11-08-2018 10:02 PM

3 Attachment(s)
Quote:

Originally Posted by 5picker (Post 1967928)
Were the tubes warm on electric operation before you switched to LP?
If so, the fuses are fine.

I think you have a bad cooling unit.

If the flue and some of the tubes get warm in both modes of operation but the refrigerator doesn't cool, it likely went bad.

5picker was right, mystery solved. Ammonia leak was behind the burner can. The
fridge was under warranty. Called the dealer that installed it about one year ago and he agreed to file a warranty claim with Dometic. Hopefully they will send a new unit. See picks below of the leak area.
Thanks for all your help.

5picker 11-08-2018 11:30 PM

Well it stinks (literally) that it went bad but glad to hear you have warranty.

Best of luck going forward.

MR.M 11-09-2018 09:13 AM

Quote:

Originally Posted by John24RLS (Post 1968392)
5picker was right, mystery solved. Ammonia leak was behind the burner can. The
fridge was under warranty. Called the dealer that installed it about one year ago and he agreed to file a warranty claim with Dometic. Hopefully they will send a new unit. See picks below of the leak area.
Thanks for all your help.

That a good picture of the remnants of a leak. I'm sure dometic will send a new cooling unit


All times are GMT -5. The time now is 06:28 PM.