Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   FR3 (https://www.forestriverforums.com/forums/f232/)
-   -   Passenger camera not working (https://www.forestriverforums.com/forums/f232/passenger-camera-not-working-178135.html)

Iankerr 02-03-2019 10:05 AM

Passenger camera not working
 
Hi does anyone have the fix for the right camera. Before I start tracing wires?

Witch Doctor 02-03-2019 01:43 PM

Quote:

Originally Posted by Iankerr (Post 2017647)
Hi does anyone have the fix for the right camera. Before I start tracing wires?

You shouldn't have to trace, most just plug in the back if it's like mine there are 3 leads 1 for each camara they just plug in the back of the screen, now mine is a jenson entertainment center with the GPS. To make sure it's the camara unplug one and plug the other side in to see if it works, has to be either the camara and wire or the unit. Just had to replace my whole system I just had a blank screen. It was replaced under warranty by Coachmen. I think there is a 2 year warranty on most ,so 1 year from the dealer and a 2nd year from the manufactor.

kenandterry 02-03-2019 02:03 PM

Quote:

Originally Posted by Witch Doctor (Post 2017798)
You shouldn't have to trace, most just plug in the back if it's like mine there are 3 leads 1 for each camara they just plug in the back of the screen, now mine is a jenson entertainment center with the GPS. To make sure it's the camara unplug one and plug the other side in to see if it works, has to be either the camara and wire or the unit. Just had to replace my whole system I just had a blank screen. It was replaced under warranty by Coachmen. I think there is a 2 year warranty on most ,so 1 year from the dealer and a 2nd year from the manufactor.

X2 on the troubleshooting


All times are GMT -5. The time now is 07:43 AM.