Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   Roo | Shamrock (https://www.forestriverforums.com/forums/f46/)
-   -   Driver side turn/brake signal (https://www.forestriverforums.com/forums/f46/driver-side-turn-brake-signal-216508.html)

Drewborn 09-14-2020 06:11 AM

Driver side turn/brake signal
 
Hi,
Had a wonderful weekend at Harper's Ferry KOA with the fam in our 21DK. After breaking down camp to return home, the driver side blinker and brake signal would not work. I removed the exterior cover and one of the two filaments on the bulb was working. I replaced it and saw the same issue. The running filament was fine, but the brake and turn filament was producing no light.

Does anyone have a recommendation on the next steps to diagnose? I am going to recheck the vehicle and camper fuzes but after that have no idea how to troubleshoot. Thanks in advance.

Oaklevel 09-14-2020 06:13 AM

Check the towing (trailer) fuses on your tow vehicle.They can be seperate from the regular tow vehicle turn fuses. (Check your owners manual to see if this is the case)

My Dodge has more two fuses for the trailer left and right.

:signhavefun:

Drewborn 09-17-2020 08:33 AM

So I hooked up my neighbors vehicle and still have the same issue so the problem is isolated to the camper. Would anyone have a recommendation on how to proceed with troubleshooting? Thanks!

hobienick 09-17-2020 09:25 AM

Make sure the connections at the light from the inside are still good. I know I bump into the wires on mine since it is in a storage space.

Also, you can check continuity from the trailer plug to the light itself. You can try swapping bulbs to see if the bulb is bad.

Chuck_S 09-17-2020 06:07 PM

Turn the hazards on and start checking for pulsing voltage starting from the junction box just under the front edge of the trailer where the umbilical cord enters. If no 12v there the problem is your cord. If not keep working toward the rear of the trailer.

Look for a torn wire.

-- Chuck

dseepersad 09-18-2020 06:29 AM

I'm having a similar issue, but worse. For running lights we only have 2 working on the top left, the middle and top 2 on right don't light up. We only have a right turn/brake signal, left isn't working. We tested the tow vehicle and all is good there. We are not mechanically inclined so, we'll take the camper in to a service center to get it checked out.


All times are GMT -5. The time now is 12:34 AM.