Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   Plumbing and Water Systems & Fixtures (https://www.forestriverforums.com/forums/f217/)
-   -   New Salem hemisphere water pump won’t pump water (https://www.forestriverforums.com/forums/f217/new-salem-hemisphere-water-pump-won-t-pump-water-216912.html)

Kammam 09-19-2020 08:47 PM

New Salem hemisphere water pump won’t pump water
 
I purchased a new 2021 Salem Hemisphere 370BL. I went to test the water pump for the first time and it will not pump water unless it is connected to a hose. We tried replacing the pump and the same problem occurred. There is plenty of water in the holding tank. Any ideas??

glen1971 09-19-2020 08:53 PM

Is your trailer equipped with a hose for winterizing next to the pump? Is the valve for it in the right position? Have you tried changing the position?

Kammam 09-19-2020 09:57 PM

Yes to all of the above.

Kammam 09-19-2020 10:06 PM

I believe I either have an air leak or something on the inlet side. I have primed the whole system via the winterization tube with a hose from my house. pump will shut off as it should and all lines to all faucets are full. Once I turn any faucet on it runs water for a few minutes and then peters out and just goes to blowing air. I only have the one valve on the inlet side before the pump. Now if I blow through the inlet hose it just blows air straight through. I have connected a shop vac to the inlet hose and can’t really get any water to come in to my vacuum but may be a glass full or so. Any suggestions on where the fresh water tank is I believe the line is either damaged, kinked or has an air leak. I do know the line is going into the tank because when I prime it through the winterization hose it is actually filled up my tank from trying it so many times LOL. PS I don’t have any water leaking out from under the coach anywhere . Thanks in advance for any help!

Mikeytheb 09-20-2020 01:14 PM

Due to weather reasons when we picked up our Salem Hemisphere we were graciously allowed to “camp” at dealer before we left with unit. They connected us to standard 120V plug and filled the fresh water tank. During the filling the tech noticed something not quite right. They started investigating and identified a pinched hose in the water/pump system. Spent several hours repairing on the lot before they left for the night. Tech said not that uncommon as FR runs those water lines near/through wheel well area and they get pinched all the time. Could just as easily be pinched and pierced - thus the air only and leaking situation you are experiencing.
A little different symptom but they noted there was an anomaly while trying to fill fresh water tank for us. Would only get about half full.

5picker 09-20-2020 02:02 PM

Do you have a ShowerMiser valve in your shower?
Is it in the proper position?
Also, some of them have cracked, causing pump suction issues.


All times are GMT -5. The time now is 06:12 PM.