Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   Salem (https://www.forestriverforums.com/forums/f26/)
-   -   Bad pump? (https://www.forestriverforums.com/forums/f26/bad-pump-217304.html)

vtraudt 09-25-2020 07:07 AM

Bad pump?
 
Bought the 2018 Slam Cruise Lite 241QB used.

The water pump is turning but not pumping. No 'sucking' sound on the inlet, no water getting sucked up.

I will take the pump out today and prime by hand to see if it can be resurrected. I assume it had been left running dry for long time (switch on when it is was connected to vehicle (and got power) during transport here).

I want to look up and prepare order of a replacement pump.

What do I need to order (make/model or link)?

vtraudt 09-25-2020 07:25 AM

Just get a Shurflo 2088-554-144 Fresh Water Pump, 12 Volts, 3.5 Gallons Per Minute, 45 Psi ?

Want to make sure connections fit!

KyDan 09-25-2020 07:33 AM

You don't mention if it's worked for you. Could be an open valve or cap missing on a winterization line that's used to pump antifreeze thru the system when done for the season.
You'll need to access the pump and look for a T or extra line on the suction side. One line comes from the fresh tank, the other (if you have one) is for sticking in a jug of pink antifreeze. There might be a valve to switch from one to the other.
Might be a cap on the antifreeze line that's loose or missing.
Typically running a pump dry won't harm it. There's exceptions to every rule tho.
Water pumps are readily available online. I bought one on Ebay and of course Amazon and RV suppliers have them.
You don't have to use the exact same model replacement.

Go to Ebay.com and search for RV water pump. Lots to choose from. Shurflo is a popular brand. Most run about $60 incl shipping.
Good luck!

vtraudt 09-25-2020 08:01 AM

Quote:

Originally Posted by KyDan (Post 2420704)
You don't mention if it's worked for you.

I have city water connected, working fine. No leaks.
Water tank drain was open, noticed when I filled the tank. Closed.

The one pump listed above claims 3.5 gpm and 35 psi.

vtraudt 09-25-2020 12:39 PM

I took the pump out and primed it. Working now.
Question is: next time it will be stored for a while, will it also not prime again?
Never had issues with pump when stored for a year (or half year) like this.

Its 2018, so it does not have many 'miles' on it.

KyDan 09-25-2020 02:01 PM

You'll probably be fine next time. One suggestion- when first starting be sure there is no pressure in the system. Open a faucet and wait for the pump to start pumping water.

vtraudt 09-25-2020 04:06 PM

I take my chances, on Amazon with prime it takes a few days to get one.


All times are GMT -5. The time now is 01:17 AM.