Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   Appliances and Electronics (https://www.forestriverforums.com/forums/f113/)
-   -   genesis 3.0 DVD surround sound issues (https://www.forestriverforums.com/forums/f113/genesis-3-0-dvd-surround-sound-issues-25700.html)

thefeniuks 07-03-2012 05:20 PM

genesis 3.0 DVD surround sound issues
 
We have an 8312ss and for some reason only certain DVD will play voice over all the speakers. Some we have to turn up load and they only play on the bedroom and right front speaker. Other DVD work fine. Help

Rockinwood 08-08-2012 05:06 PM

Quote:

Originally Posted by thefeniuks (Post 217899)
We have an 8312ss and for some reason only certain DVD will play voice over all the speakers. Some we have to turn up load and they only play on the bedroom and right front speaker. Other DVD work fine. Help

Looks like no one posted back to you, I just saw this myself, depends what the dvd output is, some, most new ones Either get a 5.1 recording (most of the movie DVD's feature this), or some will only usually older, will be only 2 channel.

ependydad 08-08-2012 06:02 PM

I wish anyone had more information on this. I couldn't get the first two Chronicles of Narnia to play over our DVD player w/ the surround sound. The DVDs say that they're Dolby 5.1, but I could only get the voices to work if I switched the DVD player to have 2 channel output - even then, the sound levels were off.

I even (GASP!) opened the manual - it was worthless with just screen captures of each menu page w/ no descriptions, suggestions or ANYTHING.

Bob Fields 08-14-2012 12:33 PM

Try resetting the units to factory defaults by pressing and holding the MODE button (with the power on) until the units shut off. Then try again.

No one should ever really need to touch any of the setup functions and factory default will pay surround sound.

ependydad 10-16-2012 06:37 PM

Well, 2 months later- I finally got a friend to help me look at this. I have to say that I'm disappointed with my Genesis - it didn't magically send any output to my center channel speaker. After pulling the head unit out, the cable was clearly laying next to all of the others! (Sarcasm.)

Hooked that up and all is well.

TURBS 10-16-2012 07:32 PM

Quote:

Originally Posted by ependydad
Well, 2 months later- I finally got a friend to help me look at this. I have to say that I'm disappointed with my Genesis - it didn't magically send any output to my center channel speaker. After pulling the head unit out, the cable was clearly laying next to all of the others! (Sarcasm.)

Hooked that up and all is well.

Glad you found it!


All times are GMT -5. The time now is 06:53 AM.