Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   Appliances and Electronics (https://www.forestriverforums.com/forums/f113/)
-   -   Thermostat says E2 (https://www.forestriverforums.com/forums/f113/thermostat-says-e2-25800.html)

Subsity 07-05-2012 06:32 PM

Thermostat says E2
 
I apologize I am new and hope I am not posting in the wrong section. I have a 2011 surveyor eco light and I went to work and shut off my ac and when I came back my Thermastat displays E2 and does not want to cool. The fan turns on but can't cool. Please let me know what I need to do.

VinceU 07-05-2012 07:00 PM

Quote:

Originally Posted by Subsity (Post 218635)
I apologize I am new and hope I am not posting in the wrong section. I have a 2011 surveyor eco light and I went to work and shut off my ac and when I came back my Thermastat displays E2 and does not want to cool. The fan turns on but can't cool. Please let me know what I need to do.

Try Dometic site for SZLCD (single zone LCD) thermostat. On the net its got installation and operation instrucs for this unit. I remember E2 but won't swear to what is was. This thermo looks simple but its anything but. Hopefully this will get you out of " hot water".

Triguy 07-05-2012 10:12 PM

Subsity,
Is this a Dometic single zone LCD t-stat and was the trailer sitting in very hot temps? If so, then it's been an issue for a few years and there are solutions. Check out this thread starting at post 15 ...

Dometic AC

In short, try cutting the power to your trailer. Also, try cooling down the thermostat with compressed air or a bag of ice. The t-stat needs to be below 110 degrees fahrenheit. Good luck.

Also, call your dealer and ask for a replacement.

jtstromsburg 07-05-2012 10:13 PM

I believe E2 is error fort high temp. Ours will say that when it gets warmer than 100 inside the camper. I usually open windows and turn on the roof vent fans and a room fan for a bit till it kicks in.

Subsity 07-05-2012 10:17 PM

I believe that did the trick thanks guys I had to cool it down and shut the breaker off and it worked after ten mins with a cold compress .I will just leave it on from now on. Thanks for the quick replies I greatly appreciate it. :)

Triguy 07-05-2012 11:16 PM

Good to hear it! :thumbsup:


All times are GMT -5. The time now is 10:59 AM.