Forest River Forums

Forest River Forums (https://www.forestriverforums.com/forums/)
-   Plumbing and Water Systems & Fixtures (https://www.forestriverforums.com/forums/f217/)
-   -   Water Heater Recovery (https://www.forestriverforums.com/forums/f217/water-heater-recovery-65604.html)

AMAZINFAN69 07-31-2014 02:03 PM

Water Heater Recovery
 
I have a suburban water heater and when you use the hot water it won't stay running. I am not sure if it is the thermostat, thermo coupling or a dirty burner assembly. Here is some info, it runs on propane but has and electric igniter and when you use the water you can hear the click of the igniter and the blower kick on but won't stay lit. It does this about 3 times and then stops trying to light, I turn the switch on and then off inside and most times it will turn on and recover. Any thoughts or ideas before I start replacing things? I am going to try to clean out the burner and the thermo coupling this weekend and hope that's all it is, thoughts???? Thanks

TURBS 07-31-2014 02:13 PM

How are you turning the water heater on and off?

There should be no blower starting up.

TURBS

"SABRE OWNERS UNITED"

DaveSchwartz 07-31-2014 03:33 PM

I had a similar problem with the WH in my previous TT. It would do that and I would open the cover and play with the push-on wire connectors to the control module and it would work again for a few hours. I couldn't see anything wrong with the connectors but I replaced a few of them and never had another problem in 7 years.

AMAZINFAN69 07-31-2014 09:37 PM

Quote:

Originally Posted by f1100turbo (Post 670712)
How are you turning the water heater on and off?

There should be no blower starting up.

TURBS

"SABRE OWNERS UNITED"

I am turning the switch inside the camper off then on, you then hear the heater try to light and the exaust fan or whatever it is turn on. It does this a few times and then stops.

rockfordroo 07-31-2014 09:51 PM

No blowers on the water heater.

TURBS 07-31-2014 09:53 PM

Quote:

Originally Posted by rockfordroo (Post 670988)
No blowers on the water heater.

That's what I'm trying figure out.

Furnace and a/c should be only blowers.

Unless it's tankless?

What model suburban w/h?

Does the electric side work?
TURBS

"SABRE OWNERS UNITED"

wmtire 07-31-2014 10:07 PM

Guys, I believe the OP is talking about the sound the burner makes when the gas lights. It can sound like a blower fan or similar.

As far as the original questions, there is a chance the flue is stopped up, as spiders love to make homes as well as dirt dobbers in them.

I think you are on the right troubleshooting track Amazinfan69. You can also download a Suburban manual for troubleshooting it even more from our library:

https://www.forestriverforums.com/for...rt=date&page=2

Pages 13, 14, and 22 of the operation/service manual above may help you in the understanding of the heater and what to check.

Good luck

AMAZINFAN69 08-01-2014 05:12 AM

Quote:

Originally Posted by wmtire (Post 671001)
Guys, I believe the OP is talking about the sound the burner makes when the gas lights. It can sound like a blower fan or similar.

As far as the original questions, there is a chance the flue is stopped up, as spiders love to make homes as well as dirt dobbers in them.

I think you are on the right troubleshooting track Amazinfan69. You can also download a Suburban manual for troubleshooting it even more from our library:

Forest River Forums - Downloads - Plumbing, Propane and Water Systems

Pages 13, 14, and 22 of the operation/service manual above may help you in the understanding of the heater and what to check.

Good luck

wntire, you are correct I am referring to the "blowing sound" the heater makes thank you. I am going to camp tonight I will clean the flue out and the thermo coupling as well and see what happens and thanks for the download.

AMAZINFAN69 08-08-2014 05:11 AM

Ok so here is where I am at now, I turn on the water heater button inside the camper and the little red light comes on. The water heater ignites and the little red light goes out and I can hear the ticking and the gas come on. This happens for about 5 sec and the burner shuts off and the red light comes back on, this does that 3 times and goes into lock out mode. I am thinking thermostat/high limit switch but have no way to test, any suggestions?

AMAZINFAN69 08-08-2014 10:49 AM

Spoke to RV dealer and he says since I blew it out the burner might be clogged but if not sounds like the module board. Thoughts on this how hard is it to change and any tips to clean the burner?

AMAZINFAN69 08-19-2014 09:30 AM

Just in case anyone else has this problem my Module Board was bad. Been two weekends and hot water is good. Thanks to all who help with this......

wmtire 08-19-2014 09:35 AM

Good deal. Thanks for completing this thread with the solution to your problem. This may help other members in the future, who may do a search for a similar problem.


All times are GMT -5. The time now is 09:33 PM.